Trijicon REAP-IR issues

Discussion in 'Night Vision/Thermal' started by saki302, Feb 24, 2021.

  1. saki302

    saki302 New Member

    Joined:
    Feb 23, 2021
    Messages:
    2
    Hello all!

    I have a REAP-IR unit which worked fine for a while, but recently has been giving me trouble.

    Mine is a 35mm REAP-IR (mfr 2016) which developed a strange issue where it would show a split screen on boot and not function (goes to a white fuzzy unresponsive screen)- but if you turn it on and off several times, eventually you get a "good" boot and it works. It will work fine until you turn it off - then same issue again, turn it on and off several times until you get another 'good' boot.

    This sounds like a software/firmware issue. Hardware either works or it doesn't

    I contacted trijicon, and they told me to send it in- sounded like they were going to take care of it.
    After about 4 weeks, they contact me saying the repair would cost me nearly $5K (new core, new main board).
    This doesn't sound right, as it works *sometimes* if you keep turning it on and off. It really sounds like a software issue.

    If they cannot cover the repair I will have them send it back, as it's not worth the repair cost, I could just buy another, and this does work provided you do the magic chicken bone dance and turn it on and off 4-6 times.

    Has anyone figured out how to self-reset or address this issue? I have already contacted texaslawman to see if he knows anyone at Trijicon who can help- I saw it mentioned in another thread he may.

    Thanks in advance!

    -Dave
     

Share This Page