Pulsar's QD Mount..... worth trying out?

Discussion in 'Night Vision/Thermal' started by 1187Shooter, Dec 21, 2017.

  1. 1187Shooter

    1187Shooter New Member

    Joined:
    Oct 12, 2017
    Messages:
    11
    Well, I went with an Apex XQ38, and love it. Except the mount... it seemed nice and solid at first, and it does seem to be built well, but it shook loose twice on me during my trip to Texas.
    Originally I was going to leave the thermal permanently installed on one rifle, (.277 Wolverine build) but after using the scope I think I'd like to be able to put it on my 270WSM once in a while, as well.
    Looking at the Pulsar QD mount, it only has one mounting/locking point whereas most others seem to have two... has anyone tried this mount? It's at a good price on Pulsar's website right now, but if it's not reliable, I'd rather spend a little extra on a better one.

    (This guy was shot with the 270WSM, not the rifle with the Thermal.)
    [​IMG]
     
    Curly Shuffle and theblakester like this.
  2. Wray

    Wray LSB Member

    Joined:
    Nov 23, 2017
    Messages:
    32
    Location:
    Gonzales
    I ordered it weeks ago but they show out of stock
     
  3. Steve

    Steve LSB Member

    Joined:
    Mar 15, 2017
    Messages:
    53
    Yes, I have one right now and been using it a month or so. So far the mount has worked flawlessly. I would not recommend spending the ridiculous price of $250 when you can get this Pulsar mount that works just as good for $40.
     
  4. Mark

    Mark New Member

    Joined:
    Oct 23, 2016
    Messages:
    22
    I dunno, I just can't use a $40 mount on a $5,000 thermal scope and expect it to work as well as the $250 dollar mount. Things just dont work out that way.

    The D-loc and the Pulsar after market mount both have good reviews though.

    If the $40 dollar mount works for you though then go for it.
     
  5. Jhop

    Jhop LSB Active Member SUS VENATOR CLUB

    Joined:
    Aug 29, 2015
    Messages:
    664
    Location:
    Copperas Cove, Texas
    If it makes y'all fell better, the $40 is only an introductory price. The price is supposed to go up well over $100
     
    Pootie likes this.
  6. Steve

    Steve LSB Member

    Joined:
    Mar 15, 2017
    Messages:
    53
    If it makes you feel any better Mark, the trail line have known problems and issues with returning to zero. Its not the mount FYI.
     
  7. Mark

    Mark New Member

    Joined:
    Oct 23, 2016
    Messages:
    22
    Known problems and issues? Are you reading about this online? If so, can you post a few links I would like to read up on it. Good to know...thanks
     
  8. dtfromaust

    dtfromaust New Member

    Joined:
    Dec 30, 2017
    Messages:
    2
    Location:
    Padthaway, Australia
    Is that to do with the zero moving with temerature change???
    Ive had 2 Xp50's tbat have had this issue. Im not sure how big a problem it is but Im at wits end with it.
     
  9. gshock

    gshock Banned Member! SUS VENATOR CLUB LoneStarBoars Supporter

    Joined:
    Nov 27, 2014
    Messages:
    1,581
    My Apex Pulsar XD50A held zero okay for a while then I noticed the screws holding the scope to the mount came loose. I put a little blue locktite on the screws. Seems OK for now, need to see how it holds up over time.
     
  10. dtfromaust

    dtfromaust New Member

    Joined:
    Dec 30, 2017
    Messages:
    2
    Location:
    Padthaway, Australia
    Its the trail model that Im having problems with, not the apex
     
  11. gshock

    gshock Banned Member! SUS VENATOR CLUB LoneStarBoars Supporter

    Joined:
    Nov 27, 2014
    Messages:
    1,581
    Dont have much experience with the trail lines ... I was responding to the OP ;)
     
    dtfromaust likes this.
  12. Wray

    Wray LSB Member

    Joined:
    Nov 23, 2017
    Messages:
    32
    Location:
    Gonzales
    I received word today the Pulsar branded (or sold) mounts won't be in until late Jan-early Feb.
     
  13. 437

    437 LSB Active Member

    Joined:
    Jan 25, 2017
    Messages:
    604
    I have their QD mount on my RXQ it leaves a lot to be desired for sure simply due to the fastening mech. Mine works and I'm used to it and I had the pic rail notch come loose, but used loctite no more issues. Had it since late May no zero issues or antying liek that. I like that zero delta? Not sure if that is the name buddy has one super slick.
     

Share This Page