LWRC REPR issues

Discussion in 'Firearms; Rifle, Shotgun, Pistol, accessories.' started by waverider, Nov 8, 2017.

  1. waverider

    waverider LSB Member

    Joined:
    Oct 4, 2016
    Messages:
    49
    Location:
    Fort Worth, TX
    The gun runs just fine w/o a suppressor on it, but below are a few photos of the intermittent issue ejecting the casing since adding the suppressor. The gun has an adjustable gas regulator and the issue is the same in the "normal" position and the "suppressed" position.

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    Running good ammo...both Barnes and Nosler.
    Suppressor is a Dead Air Sandman - S

    Thoughts?
     
  2. RattlesnakeDan

    RattlesnakeDan San Antonio Texas LSB TURKEY BUZZARD PRESERVATION SOCIETY SUS VENATOR CLUB LoneStarBoars Supporter

    Joined:
    Aug 7, 2013
    Messages:
    4,075
    Location:
    San Antonio, Texas
    Ejector springs may be weak or gummed up.
     
  3. Curly Shuffle

    Curly Shuffle LSB Active Member SUS VENATOR CLUB LoneStarBoars Supporter

    Joined:
    Aug 9, 2014
    Messages:
    2,293
    Location:
    Kemah, Texas
    Just reread your post and it is an LWRC,, heck man I would call them they should tell you what the problem is. And Dan has a good point too?? Must be clean. BANG BANG!!!
     
  4. Rookie

    Rookie LSB Member

    Joined:
    Sep 26, 2017
    Messages:
    61
    Mine does it unless I run the bolt wet. Try lubing the BCG really well and don't wipe off the excess.
     
  5. waverider

    waverider LSB Member

    Joined:
    Oct 4, 2016
    Messages:
    49
    Location:
    Fort Worth, TX
    Thanks for the insight guys. I'll try that out first, then if that doesn't work I will follow up with LWRC.
     

Share This Page